כלים של משתמש

כלים של אתר


תוספת_אבטחה_להפעלת_java

אבטחה ב- Java

בגרסאות עדכניות של Java קיימת הגדרות אבטחה פנימיות ל- Java, וקיימת צורך לאשר הפעלת תכנות Java דרך הדפדפן.

  • תכנת ה- MathNet חתומה בחתימה דיגיטלית על מנת לאפשר את הפעלתה בצורה בטוחה.
    • אך קיים צורך לאפשר את הפעלתה על ידי מתן אישור במחשב המשתמש.
      • Image of Java's 'Do you want to run this application' dialog with the Run button circled.
    • ניתן לתת אישור “קבוע” על ידי סימון התיבה לא להראות שוב את הבקשה לאישור לפני הלחיצה לאפשר את הפעלת התוכנה.
      • Image of Java's 'Do you want to run this application' dialog with the checkbox not to ask again marked and circled.
  • ניתן לעבוד עם MathNet כאשר רמת האבטחה (Security Level) ב- Java Control Panel היא “Very High” (ברירת המחדל בהתקנה) או “High”.
    • במידה ונתקלים בתקלות, מומלץ לנסות ב- “High”.
    • לאחר שינוי רמת האבטחה יש לסגור את כל חלונות הדפדפן, ולהפעילו מחדש.
  • יש צורך לאשר את הפעלת תוכנת המתנט, אך
  • במקרה שרואים הודעה מהסגנון הבא יש לנסות ברמת אבטחה “High”.
    • Application Blocked by Security Settings
    • Name: tut (בפתיחת שאלות) או smallTestApplet (בדף הראשי לאחר הכניסה לחשבון)
    • Your security settings have blocked untrusted application from running
  • קיימת גם אפשרות להוסיף את אתר ה- MathNet לרשימת אתרים מורשים (Exception Site List), במידה ויש בעיות מיוחדות. באופן כללי, צעד זה אינו הכרחי.

הערות נוספות

המלצות למשתמשי הדפדפן Chrome

הדפדפן Chrome הפסיק לתמוך בתוסף Java, אבל אפשר לשמור קבצי JNLP ואז לפתוח אותם.

תוספת_אבטחה_להפעלת_java.txt · מועד השינוי האחרון: 2018/03/18 11:35 על ידי techdesk